POODLE vulnerability mitigated

The security of our customers and their data is our highest priority. A potential SSL vulnerability has been identified by Google researchers. This vulnerability, called POODLE, makes it possible for an attacker to break through an SSL connection’s encryption. We have updated our servers with the recommended fix and are no longer vulnerable to this newly identified threat. We have no reason to believe that any customer data has been compromised.

Leave a Reply